رتبه موضوع:
  • 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
آموزش قدم به قدم سیسکو
#1
HyperTerminal

چطور از Hyper Terminal براي ارتباط با سوئيچ يا روتر سيسكو استفاده كنيم.
تجهيزات سيسكو زيادي داراي محيط گرافيكي Web-Base نيستند لذا شما بايد در محيط Command به آن وصل شده و تنظيمات خود را انجام دهيد. در اين نوع ارتباط بايد از كابل سريال استفاده نموده و سوئيچ يا روتر خود را از طريق پورت سريال به كامپيوتر خود مرتبط سازيد. پس از ارتباط سخت افزاري از طريق اين كابل بايد از نرم افزاري استفاده كنيد تا به كنسول دستگاه سيسكو خود مرتبط شويد. نرم افزارهاي بسياري اين مهم را عملي مي سارند اما ساده ترين و در دسترس ترين آن ها Hyper Terminal خود سيستم عامل شماست. در اين نوشتار شما خواهيد آموخت چطور با اين نرم افزار مي توان به كنسول دستگاه سيسكو خود مرتبط شويد.
Hyper Terminal چيست ؟
HyperTerminal نرم افزاري تحت ويندوز است و امكان ارتباط متني با دستگاه مرتبط به كامپيوتر شما را فراهم مي آورد و اين دستگاه مي تواند هر دستگاه تحت شبكه داراي پورت سريال را شامل شود. همچنين از Hyperterminal مي توانيد به عنوان يك اينترفيس محلي براي ايجاد ارتباط يا ايجاد شبكه استفاده كنيد. در خصوص استفاده در شبكه ، HyperTerminal به راحتي قادر به استفاده از پروتكل Telnet مي باشد.

به مسير زير رفته و نرم افزار HyperTerminal را اجرا كنيد.

Start > Programs > Accessories > Communications > HyperTerminal.

بعد از اينكه روي آيكون HyperTerminal كليك كرديد شكل زير پديدار مي شود.
Hyperterminal-1

[عکس: Hyperterminal-1.jpg]
HyperTerminal از شما مي خواهد تا Connection اي را ايجاد كنيد. انجام اين قسمت ضروري نيست اما پيشنهاد مي كنم آن را تكميل كنيد. به عنوان مثال تايپ كنيد “Cisco” و دكمه “OK” را كليك كنيد. در اين مرحله دستگاه Cisco خود را به پورت COM مرتبط سازيد ولي آن را روشن نكنيد. در پنجره بعدي چك كنيد كه حتما پورت COM1 را انتخاب كرده باشيد و دكمه OK را بزنيد.
Hiperterminal-2
[عکس: Hiperterminal-2.jpg]

در پنجره بعدي Baud rate را 9600 تنظيم كنيد و كليد OK را بزنيد.
Hiperterminal-3

[عکس: Hiperterminal-3.jpg]

حال دستگاه سيسكو خود را روشن كنيد در پنجره Hyper Terminal شما بايد قادر باشيد تا مراحل بوت شدن دستگاه خود را ببينيد. نظير شكل زير :
Hiperterminal-4
[عکس: Hiperterminal-4.jpg]
شما با موفقيت HyperTerminal را تنظيم كرده و به دستگاه سيسكو خود وصل شديد. درصورتيكه قادر به ديدن بوت شدن دستگاه خود در پنجره Hyper Terminal نيستيد لطفا ارتباط دستگاه به كامپيوتر خود را مجدد چك كنيد و از سلامت كابل سريال خود اطمينان حاصل كنيد. همچنين مراحل تنظيم نرم افزار را مجدد چك نماييد.
پس از اتمام كار و زمان قطع ارتباط از شما خواسته مي شود درصورتيكه كه اين ارتباط را مي خواهيد در آينده مجدد برقرار كنيد آن را ذخيره نماييد. پيشنهاد مي كنم براي آن نامي انتخاب كرده و آن را روي كامپيوتر خود ذخيره نماييد لذا در آينده ديگر نياز به تنظيم مجدد آن نيست.
ساير كاربردهاي HyperTerminal
HyperTerminal همچنين براي Telnet كردن به دستگاه تحت شبكه سيسكو مورد استفاده قرار مي گيرد.
Hyper Terminal براي Paste نمودن دستورات سيسكو بر روي دستگاه سيسكو شما قابل استفاده است. شما مي توانيد از دستور Show Running-congifاستفاده كنيد و خروجي را در windows cliboard كپي كنيد يا اينكه آن را در notepad ذخيره كنيد آن را ويرايش نماييد و يا حتي آن را مجددا در تنظيمات Routerخود استفاده نماييد.

جمع بندي : آنچه كه من در اين نوشتار به آن اشاره كردم عبارتند از :


- HyperTerminal نرم افزاري تحت ويندوز است كه با پورت سريال كار مي كند.
- از HyperTerminalمي توانيد براي تنظيم دستگاه هاي سيسكو استفاده نماييد. با پورت سريال COM كار مي كند و سرعت 9600را بايد براي اين ارتباط انتخاب كنيد.
- از HyperTerminal براي Telnet كردم دستگاه هاي تحت شبكه نيز مي توانيد استفاده كنيد.
- ساير كارهايي كه مي توان با HyperTerminal انجام داد عبارتند از Cut/Copy/Paste نمودن دستورات و logging كردن به Sessionها



نويسنده : كيانوش مراديان (وب سايت تخصصي شبكه )
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط morteza ghaem
#2
نويسنده : كيانوش مراديان
تاريخ انتشار : بيست و دوم تيرماه هشتاد و هشت

يكي از نگراني هاي مديران شبكه برخورد با دستگاه هاي سيسكوي مي باشد كه كلمه عبور آن ها فراموش شده و يا اينكه توسط شخص ديگري ايجاد شده است لذا در اين نوشتار به روش بازيابي Enable Password و Enable secret مي پردازم. اين كلمه هاي عبور براي اين ايجاد شده اند تا دسترسي را به مد تنظيم و مد تنظيمات دستگاه محدود سازند. در اينجا به اين نكته بايد اشاره كنم كه Enable Password قابل بازيابي است Enable Secret بخاطر اينكه در دستگاه كد گذاري مي شود تنها قابل جايگزيني با يك كلمه عبور ديگر است. در ادامه با اين روش ها آشنا خواهيد شد. قابل ذكر است كه روشي كه در اينجا بيان مي كنم طبق وب سايت سيسكو تنها براي مدل هاي زير قابل استفاده است.

1. • Cisco 806
2. • Cisco 827
3. • Cisco uBR900
4. • Cisco 1003
5. • Cisco 1004
6. • Cisco 1005
7. • Cisco 1400
8. • Cisco 1600
9. • Cisco 1700
10. • Cisco 2600
11. • Cisco 3600
12. • Cisco 4500
13. • Cisco 4700 • Cisco AS5x00
14. • Cisco 6x00
15. • Cisco 7000 (RSP7000)
16. • Cisco 7100
17. • Cisco 7200
18. • Cisco 7500
19. • Cisco uBR7100
20. • Cisco uBR7200
21. • Cisco uBR10000
22. • Cisco 12000
23. • Cisco LS1010
24. • Catalyst 2948G-L3
25. • Catalyst 4840G • Catalyst 4908G-L3
26. • Catalyst 5500 (RSM)
27. • Catalyst 8510-CSR
28. • Catalyst 8510-MSR
29. • Catalyst 8540-CSR
30. • Catalyst 8540-MSR
31. • Cisco MC3810
32. • Cisco NI-2
33. • Cisco VG200 Analog Gateway
34. • Route Processor Module

سعي مي كنم مراحل را بصورت مرحله مرحله بيان كنم تا بتوانيد در صورت نا آشنا بودن با جزئيات ، كار خود را بخوبي به پايان برسانيد.
1- كامپيوتر خود را توسط كابل آبي رنگي كه يك سر آن كانكتور شبكه و سر ديگر آن پورت سريال است (كابل كنسول) به پورت كنسول روتر متصل كنيد. براي تنظيمات Hyperterminal از تنظيمات زير استفاده كنيد.
9600 baud rate
No parity
8 data bits
1 stop bit
2- اگر به روتر و تنظيمات آن دسترسي داشتيد تايپ كنيد Show Version و Configuration Register خود را ذخيره كنيد. معمولا 0x2102 و يا 0x102مي باشد.
3- درصورتيكه دسترسي شما به هر دليلي ممكن نشد تنظيم را 0x2102 درنظر بگيريد.
4- سوئيچ را خاموش كنيد و مجدد روشن كنيد. در اينجا اين نكته را بايد اضافه كنم كه درصورتيكه روتر شما Cisco 6400 است بايد NRP يا NSP را خارج كرده و مجدد در جاي خود نصب نماييد. همچنين درصورتيكه روتر شما از سري 6x00 است و از NI-2 استفاده مي كند كارت NI2 را خارج كرده و مجدد در جاي خود نصب نماييد.
5- دكمه Break (برخي مواقع CTRL+Break) را در يك دقيقه اول بوت شدن روتر نگهداريد تا به مد ROMMON وارد شويد.
6- confreg 0x2142 را در ROMMON1 وارد كنيد در اين حالت روتر شما از Flash بدون اينكه تنظيمات را لود كند بوت بشود.
7- در ROMMON2 تايپ كنيد reset تا روتر شما خاموش و روشن شود در اين حالت روتر بدون تنظيمات شما بوت مي شود.
8- در مقابل هر سوالي كه در طول بوت شدن از شما پرسيده مي شود no را انتخاب كنيد يا اينكه از CTRL-C استفاده كنيد.
9- پس از بوت شدن كامل و پديدار شدن Promt تايپ كنيد Enable
10 – حال شما در مد Enable قرارداريد و Promt شما از Router> به Router# بايد تغيير كرده باشد.
10- نكته بسيار مهم : در اينجا بايد تنظيمات اصلي دستگاه را ذخيره كنيد يعني NVRAMخود را به حافظه دستگاه منتقل كنيد لذا مي توانيد از دستورات زير استفاده كنيد.
Configure memory يا copy startup-config running-config
11- سپس در خط بعد تايپ كنيد Write terminal و يا show runnig-config اين دستورات اين امكان را به شما مي دهند تا تنظيمات دستگاه را مشاهده كنيد. در اين تنظيمات پس از هر Interface مشاهده مي كنيد كه Shutdown است. همچنين مي توانيد كلمه هاي عبور را در حالت هاي كد گذاري شده يا بدون آن مشاهده كنيد. كلمه هاي عبوري كه كدگذاري نشده اند قابل استفاده مجدد هستند ولي در مورد موارد كدگذاري شده تنها مي توان آن ها را با كلمه اي جديد جايگزين كرد.
12- تايپ كنيد Configure Terminal و تغييرات خود را انجام دهيد. Prompt جديد بايد بصورت #hostname(config باشد.
13- از دستور Enable Secret براي تغيير كلمه عبور Enable Secret استفاده كنيد.
14- براي هريك از Interface هاي روتر خود دستور noshutdown را استفاده كنيد. كليه Interface ها بايد در حالت UP-Up باشند. (براي ديدن وضعيت اينترفيس ها از دستور Show ip interface brief مي توانيد استفاده كنيد)
15- در انتها از دستور config-register 0x2102 يا مقداري كه در مرحله دو يادداشت كرديد استفاده كنيد.
16- Ctrl-z يا دستور end را بزنيد تا به promt اوليه يعني hostname# وارد شويد.
17- حال بايد تنظيمات خود را ذخيره كنيد لذا از دستور write memory يا copy running-config startup-config استفاده كنيد.!


اميدوارم مطالب فوق مورد توجه شما قرار گرفته باشد و توانسته باشم به شما براي نگهداري و تنظيم دستگاه سيسكو سازمانتان كمك كرده باشم.



هميشه پاينده باشيد
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط morteza ghaem
#3
نويسنده : كيانوش مراديان
منبع : سايت تخصصي شبكه
http://www.persiandatanetwork.com

تغيير و نصب IOS يا سيستم عامل سوئيچ و روتر سيسكو يكي از مواردي است كه توسط مدير شبكه كامپيوتري يك سازمان صورت مي گيرد. دليل اينكار را مي توان در موارد زير خلاصه كرد :
- مانند بقيه نرم افزارها ، سيستم عامل دستگاه ها نيز داراي نقاط ضعف امنيتي هستند كه به مرور توسط توليد كنندگان شناسيايي شده و در نسخه هاي جديد سيستم عامل اصلاح مي شوند.
- اضافه شدن امكانات جديد به سيستم عامل همواره مد نظر ايجاد كنندگان سيستم عامل بوده است.
- هميشه بروزبودن و بروزنگهداشتن دستگاه ها به عنوان يك وظيفه هميشه مدنظر مديران شبكه مي باشد.
حال در ادامه به نحوه نصب و بروزرساني سيستم عامل دستگاه سيسكو ( سوئيچ ، روتر) مي پردازم. البته اين نكته را هميشه در ياد داشته باشيد كه قبل از بروزرساني از تنظيم هاي دستگاه هاي سيسكو خود نسخه پشتيبان تهيه نماييد.
قدم اول در بروزرساني تهيه آخرين ويرايش سيستم عامل ، دانلود آن است. براي اين منظور مي توانيد به لينك http://www.cisco.com/tacpage/sw-center/index.shtml مراجعه نموده و سيستم عامل متناسب به دستگاه سيسكو خود را دانلود نماييد. در اين نوشتار من IOS 3560 را براي بيان تنظيمات انتخاب مي كنم.حال تنظيمات ذخيره نشده را ذخيره نماييد. شما مي توانيد از دستور Write memoryاستفاده كنيد.
ciscorouter# write memory


از وجود فضاي لازم در Flash memory اطمينان حاصل نماييد و از Startup Configuration نسخه پشتيباني تهيه كنيد. شما از دستور Show flash براي ديدن فضاي Flash Memory مي توانيد استفاده كنيد.
در اينجا بايد TFTP Server راه اندازي نماييد تا بتوانيد ازتنظيمات نسخه پشتيبان تهيه كنيد ، Image دستگاه را ذخيره كنيد و در آخر بروزرساني را انجام دهيد. براي نصب TFTP بخاطر داشته باشيد كه IP در محدوده IP روتر استفاده كنيد و همچنين Gateway مناسب براي دستگاه سيسكو و كامپيوتر خود انتخاب كنيد.
ذخيره سازي تنظيمات بصورت زير خواهد بود.
ciscorouter# copy startup-config tftp
Address or name of remote host []? 10.10.10.2
Destination filename [startup-config]?
!!
1278 bytes c opied in 0.100 secs

تهيه Image از نسخه IOS موجود به صورت زير خواهد بود.
testrouter# copy flash: tftp:
Source filename []? xxxxx-xx-xx.121-x.XB
Address or name of remote host []? 10.10.10.2
Destination filename [xxxxx-xx-xx.121-x.XB]?

پس از تهيه نسخه پشتيبان از تنظيمات و سيستم عامل ،نوبت آن است كه نسخه جديد IOS را بارگذاري كنيد. براي اين منظور از دستور زير استفاده كنيد.
ciscorouter#copy tftp: flash:
Address or name of remote host []? 10.10.10.2
Source filename []? c3560-ipbasek9-mz.122-40.SE.bin
Destination filename [c3560-ipbasek9-mz.122-40.SE.bin]?
Accessing tftp://10.10.10.2/c3560-ipbasek9-mz.122-40.SE.bin…
Loading c3560-ipbasek9-mz.122-40.SE.bin from 10.10.10.2 (via Vlan1): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!​!!!!!!!!!!!
!!!!!!!!!!
[OK - 8295106 bytes]
8295106 bytes copied in 124.571 secs (66589 bytes/sec)

پس از اتمام نصب و انتقال IOS ، دستگاه خود را مجدد بوت نماييد تا از اجرا شدن آخرين نسخه IOS مطمئن شويد.
ciscorouter(config)#boot system flash:/c3560-ipbasek9-mz.122-40.SE.bin

اكنون روتر خود را Reload نماييد.
testrouter# reload

پس از بوت شدن دستگاه سيسكو خود بايد از اينكه آخرين نسخه IOS نصب شده است اطمينان حاصل نماييد لذا از دستور زير استفاده كنيد.
ciscorouter# sh ver

پس از انجام اين تنظيمات شما داراي سيستم عامل جديد در دستگاه سيسكو خود خواهيد شد . بايد منتظر نسخه جديد باشيد.

هميشه شاد باشيد
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط morteza ghaem
#4
پس از اينكه موفق به ارتباط با سوئيچ يا روترسيسكو خود شديد حال قادر خواهيد بود تنظيمات مقدماتي را روي آن انجام دهيد. اين تنظيمات عبارتند از :

انتخاب يك نام براي سوئيچ خود (hostname)
تخصيص Privileged Level
امن نمودنVTY Lines
Encrypt نمودن Password


الان كه به موارد بالا نگاه مي كنم مي بينم اگر به زبان انگليسي كل موارد گفته ميشد شايد بهتر بود. با اينكه شديد به حفظ زبان فارسي و بيان آن به شكيل ترين شكل معتقد هستم اما علوم كامپيوتري كمي براي من محدوديت ايجاد كرده است و درصورت ترجمه كليه اصطلاحات كامپيوتري به زبان پارسي متن را خنده آور و گاهي غير قابل فهم مي كند. حال ادامه مطلب :


انتخاب نام براي دستگاه سيسكو يا hostname :
انتخاب نامي مناسب براي سوئيچ يا روتر خود روي شبكه بسيار مفيد خواهد بود و در صورتيكه تعداد آن ها در مجموعه بيشتر شود شناسايي آن ها تنها با نام به راحتي قابل انجام است. درصورتيكه در شبكه خود بخش هاي متعددي وجود دارد انتخاب اين اسامي را مي توانيد با توجه به نام آن بخش انجام دهيد. براي تنظيم نام ابتدا بايد حق دسترسي Administrator به دستگاه خود بدهيد و سپس به حالت تنظيم دستگاه برويد. دستورات زيربراي اين منظور استفاده مي شوند.

براي بازگشت به مود اوليه از دستور disable مي توانيد استفاده كنيد.
Enable administrative privilege
Router>enable
Enter the configuration mode:
Router#configure terminal
حال براي اينكه نام روتر خود را بطور مثال به “Persiandatanetwork” تغيير دهيد از دستور Hostname استفاده كنيد

Define the hostname (the name router is changed to Persiandatanetwork)
Router(config)#hostname Persiandatanetwork
Persiandatanetwork(config)#
همانطور كه مشاهده مي كنيد نام روتر در خط هاي دستور به Persiandatanetwork تغيير پيدا مي كند.حال نوبت آن است كه Privileged level secret را تنظيم كرده و براي آن كلمه عبوري تعيين كنيد. فايده اين كار اين است كه اعمال تغييرات در سيستم سيسكو را محدود كرده و هر شخصي امكان Enable كردن سيسكو و اعمال تغييرات را نخواهد داشت. براي انجام اين منظور از دستورات زير استفاده كنيد :

Enable administrative privilege
Persiandatanetwork>enable
Enter the configuration mode:
Persiandatanetwork#configure terminal
Persiandatanetwork(config)#enable secret p3rsi@n
حال بايد براي ايمن كردن بيشتر كنسول Administrator را نيز ايمن كنيد لذا مراحل زير را انجام دهيد تا براي كنسول نيز كلمه عبور تنظيم كنيد.

Persiandatanetwork >en
Persiandatanetwork #configure terminal
Persiandatanetwork(config)#line console 0
Persiandatanetwork (config-line)#password g4S$%A2
Enable the password defined
Persiandatanetwork (config-line)#login
Use the “logging synchronous” command, so the messages appear only after you press Return
Persiandatanetwork(config-line)#logging synchronous
دستور آخر در واقع به معني Apply كردن تنظيمات شماست.
همانطور كه مي دانيد براي ارتباط از راه دور با سوئيچ يا روتر سيسكو از دستورات زيادي نظير Telnet ، ssh يا ... استفاده مي شود. اين روشها ارتباط را از طريق خطوط VTY كه از صفر تا چهار شماره گذاري شده اند برقرار ميسازند. با توجه به اين مطلب اين خطوط نيز بايد ايمن شوند و از كلمه عبور براي استفاده از آن ها استفاده شود. براي تنظيم كلمه عبور بر روي اين خطوط از دستور زير استفاده مي شود :


Persiandatanetwork >en
Persiandatanetwork#configure terminal
Persiandatanetwork(config)#line vty 0 4
Define your vty lines password
Persiandatanetwork (config-line)#password g%S$%Aa3
Enable the password
Persiandatanetwork (config-line)#login
Use the “logging synchronous” command, so the messages appear only after you press Return
Persiandatanetwork (config-line)#logging synchronous
بايد توجه داشته باشيد كه كلمه هاي عبوري كه در running-config استفاده كرده ايد بصورت Plain Text ذخيره شده اند و قبل از ذخيره نمودن نهايي آن ها بايد رمز گذاري يا Encrypt شوند. براي انجام اين منظور از دستورهاي زير استفاده كنيد :

Persiandatanetwork >en
Persiandatanetwork #configure terminal
Persiandatanetwork(config)#service password-encryption
حال براي اينكه نگاهي به تنظيمات خود انداخته باشيد از دستور زير استفاده كنيد تا محتواي Running-config را مشاهده كنيد.
Persiandatanetwork #show running-config

با زدن Enter تنظميات بصورت زير نمايش داده خواهد شد.

Building configuration...

Current configuration : 782 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Persiandatanetwork
!
enable secret 5 $1$8PBD$5nv39GC91koQbOcxfVFIe/
!
memory-size iomem 15
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
!
!
!
voice call carrier capacity active
!
!
!
!
!
!
!
!
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip http server
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
!
line con 0
password 7 1410463848410B79
logging synchronous
login
line aux 0
line vty 0 4
password 7 130252214F49252B78
login
!
!
end

Persiandatanetwork#
فراموش نكنيد كه تغييرات شما در Running-congif هستند و هنوز ذخيره نهايي نشده است. براي اينكه آن را ذخيره نماييد از دستور زير بايد استفاده كنيد.

Persiandatanetwork #copy running-config startup-config

و يا

Persiandatanetwork #write
پس از تنظيم و ذخيره سازي نهايي بايد به سراغ مباحث پيشرفته تر نظير تنظم IP يا VLan يا ... بپردازيد كه درخصوص آن ها در بخشهاي ديگر خواهم نوشت.

نويسنده : كيانوش مراديان ( وب سايت تخصصي شبكه )
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط morteza ghaem
#5
تاحالا ياد گرفتيم كه چطور بايد به يك سوئيچ سيسكو وصل شويم و چطور بايد تنظيم هاي اوليه را انجام دهيم. اما بايد بخاطر داشته باشيد كه هميشه نمي توان بصورت مستقيم و با كابل به دستگاه سيسكو خود وصل بشويم و نياز به ارتباط از راه دور ( روي شبكه) هميشه وجود خواهد داشت. شما بايد قادر باشيد از راه دور و از طريق كامپيوترتان به دستگاه وصل شويد، آن را چك كنيد ، تغييرات بدهيد و يا تنظيم كنيد. براي انجام اين منظور بايد به دستگاه خود IP بدهيد. شما بايد يك IP هم رنج شبكه براي اين منظور اختصاص دهيد. براي تنظيم IP دستگاه خود مراحل زير راب بايد انجام دهيد :
در ابتدا بايد به دستگاه خود Login كنيد دستور زير را اجرا كنيد.
Persiandatanetwork >
Persiandatanetwork> enable
رمز عبور را وارد كنيد. (درصورتيكه در مرحله قبل تنظيم نكرده ايد تنها دكمه Enter را بزنيد.)

Persiandatanetwork#
Persiandatanetwork# Config Terminal
Persiandatanetwork(config)#
Persiandatanetwork(config)#interface vlan 1
Persiandatanetwork(config-if)#
Persiandatanetwork(config-if)#ip address 192.168.200.10 255.255.255.0
Persiandatanetwork(config-if)# no shutdown
Persiandatanetwork(config-if)#end


فراموش نكنيد كه تغييرات و تنظيمات خود را حتما بايد در انتها ذخيره كنيد. براي اين منظور Running-Config را كه حكم حافظه موقت براي دستگاه دارد بايد به Startup-confg كه مانندهاردديسك دستگاه شماست كپي كنيد.
Persiandatanetworkg#copy running-config startup-config
نكته : نيازي نيست به در مراحل ورود دستور ، آن ها را كاملا تايپ كنيد. شما مي توانيد چند حرف اول را تايپ كرده و دكمه tab را بزنيد. سيستم دستور را شناسايي كرده و آن را در خط دستور كامل خواهد كرد. مورد ديگر كه بايد بدانيد اين است كه هرسوئيچ بصورت پيش فرض يك VLAN را شامل مي شود كه شما مي توانيد آن را درصورت نياز به چندين VLAN تقسيم كنيد. در اين بخش ما به كل VLAN1 آدرس شبكه اختصاص داده ايم. در مورد VLAN در بخش هاي آينده خواهم نوشت.

نويسنده : كيانوش مراديان
منبع : ( سايت تخصصي شبكه )
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط
#6
نويسنده : كيانوش مراديان
انتشار : بيست و سوم شهريور هشتاد و هشت




استفاده از سوئيچ هاي سيسكو در سازمان هاي مختلف امري عادي شده است و معمولا سازمان هاي بزرگ ترجيح مي دهند با تهيه سوئيچ هاي لايه دو و سه شبكه هاي كامپيوتري خود را ساختار يافته نموده و لايه بندي را در آن رعايت كنند. در اين نوشتار به مبحث VLANمي پردازم.


VLAN چيست ؟
VLAN همانطور كه از نام آن پيداست شبكه LAN مجازي است كه Broadcast Domain اصلي سوئيچ را كه بصورت يك VLAN وجود دارد (VLAN1) را به چندين Broadcast Domain ديگر مي شكند. به دليل اينكه سوئيچ ها قادر به برقراري ارتباط وLearn كردن از هم هستند لذا چندين پورت از سوئيچ ديگر مي تواند عضو VLAN سوئيچ ما باشد بدون اينكه Broadcast را به سوئيچ ها يا VLAN هاي ديگر منتقل كند. معمولا VLAN براي شبكه هاي بزرگ با ترافيك بالا كاربرد دارد. قبل از اينكه به نحوه تنظيم VLAN بپردازم نكاتي را كه بايد قبل از اين تنظيمات بدانيد در چند بيان مي كنم.
- VLAN در واقع يك Broadcast Domain مي باشد كه توسط سوئيچ ايجاد مي شود.
- براي تنظيم VLAN مدير شبكه ابتدا بايد VLAN را ايجاد كند و سپس پورت هاي سوئيچ را به آن مرتبط سازد.
- همه سوئيچ هاي سيسكو داراي يك VLAN بصورت پيش فرض هستند.
- در هر VLAN پورتي به نام Trunk تعريف مي شود كه قادر است ترافيك هاVLAN را به خارج يا داخل هدايت كند. اين پورت از پروتكل ISL يا 802.11q براي اين كار استفاده مي كند. با كلامي ديگر اين پورت بين چندين VLAN مشترك است و ترافيك كليه آن ها را به سوئيچ يا روتر انتقال مي دهد.
- براي ارتباط چندين VLAN از سوئيچ لايه 3 يا روتر استفاده مي شود.
حال در اينجا نحوه ايجاد VLANرا توضيح مي دهم. براي اينكه مطلب را ملموس تر بيان كرده باشم به طرح يك سناريو پرداخته و سپس دستورات مورد نياز را مي آورد.
سناريو : مي خواهم دو VLAN به شماره هاي 5 و 10 ايجاد كنيم و هدف بعدي من قراردادن پورت هاي 2 و 3 در VLAN5 و پورت هاي 4 و5 و 6در VLAN10 خواهد بود. نام VLAN5 را Marketing و نام VLAN10 را Human Resource مي گذارم. همانطور كه در بالا اشاره كردم ابتدا VLAN هاي مورد نياز را مي سازم.
Router>
Router> Enable
در اينجا كلمه عبور را وارد مي كنيم و به مد تنظيمات مي رويم.
Router# config terminal
Router (config)#
Router(cinfug)#vlan 5
Router(config-vlan)#name marketing
Router(config-vlan)#exit
Router(config)#
Router(config)#vlan 10
Router(config-vlan)name Human Resource
Router(config-vlan)#exit







تاكنون vlan هاي 5 و 10 را ساختم. حال نوبت اين است كه به هر يك از آن ها پورت هاي مورد نظرم را مرتبط كنم. براي اين كار بايد به Interface رفته و دستورات زير را وارد كنم :










Router(config)# interface fastethernet 0/2
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan5
Router(config-if)#exit
Router(config)#interface fastethernet 0/3
Router(config-if)#switch mode access
Router(config-if)#switchport access vlan 5
Router(config-if)#exit
Router(config)#interface fastethernet 0/4
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan10
Router(config-if)#exit
Router(config)#interface fastethernet 0/5
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan10
Router(config-if)#exit

Router(config)#interface fastethernet 0/6
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan10
Router(config-if)#exit

نكته : درصورتيكه چندين پورت سوئيچ را به يك VLAN مي خواهيد مرتبط سازيد مي توانيد از دستور interface range fastethernet 0/5-10 استفاده كنيد و نياز به تايپ مجدد هريك از پورت ها بطور مجزا نيست. در اين دستور پورت هاي پنج تا ده سوئيچ به يك VLAN تخصيص داده مي شوند. همچنين براي ديدن وضعيت پورت ها و VLAN ها از دستور Router(config)#show vlan اساتفاده كنيد.

فراموش نكنيد پس از انجام تنظيمات ، Running-config را در startup-config كپي كنيد و يا اينكه از دستور Write استفاده كنيد. پس از انجام اين تنظيمات بايد بدانيد در حال حاضر تنها پورت هاي 2 و 3 قادر به ارتباط برقرار كردن با يكديگر هستند و همچنين مشابه آن براي پورت هاي 4 و 5 و 6 صدق مي كند. اگر تمايل داريد بطور مثال پورت هاي دو و چهار با يكديگر تبادل بسته اطلاعاتي داشته باشند بايد از پورت ترانك و روتر استفاده كنيد. در مورد پورت ترانك و نحوه تنظيم آن در نوشتار بعدي خواهم پرداخت.

ماندگاريتان پايدار باد
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط
#7
نويسنده : كيانوش مراديان

منبع : سايت تخصصي شبكه
http://www.persiandatanetwork.com

دراين نوشتار به نحوه تنظيم پورت ترانك در سوئيچ سيسكو اشاره خواهم كرد. پورت ترانك در واقع پورت يا پورت هايي از سوئيچ است كه امكان ارتباط سوئيچ هاي مختلف را با يكديگر فراهم مي آورد. اين پورت كليه ترافيك هايي را كه از VLAN هاي مختلف ايجاد مي شود به خارج منتقل مي كند. يك پورت سوئيچ مي تواند به عنوان ترانك در يك سوئيچ تعريف گردد. در اين مختصر سعي من اين بوده است كه نحوه تنظيم اين پورت سوئيچ ترانك را بر مبناي پروتكل 802.1 q بيان كنم.
به مد تنظيم وارد شويد
Switch>
Switch>enable
رمز عبور را وارد كنيد
Switch#
Switch#config terminal
Switch(config)#
براي تنظيم پورت مورد نظر بايد Interface مربوط به آن را انتخاب كنيد.
Switch(config)#interface gigabitethernet1/1
حال بايد پورتي را كه انتخاب كرده ايد ( در اينجا gigabitethernet1/1 ) است به عنوان سوئيچ پورت انتخاب كنيد و آن را به مد ترانك برده و Encapsulate كنيد.
switch(config-if)# switchport
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk encapsulation dot1q
اين تنظيم ها پورت مورد نظر را به يك پورت تراتك تبديل مي كن
نكته : پيشنهاد مي شود Enable Logging را براي ترانك پورت فعال كنيد. براي اين منظور از دستور زير مي توانيد استفاده كنيد. :
switch(config-if)# logging event link-status
switch(config-if)# logging event bundle-status
switch(config-if)# logging event trunk-status

براي ديدن تنظيم ها خود مي توانيد از دستور زير استفاده كنيد.
switch# sh run interface gi1/1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
logging event link-status
logging event bundle-status
logging event trunk-status





درانتها تنظيمات خود را در startup-config ذخيره نماييد.
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط
#8
تنظيم SSH روي سيسكو

بسياري از مديران شبكه كاملا به اين حقيقت آگاه هستند كه استفاده از Telnet براي انتفال متون حفاظت نشده در روترها، سوئيچ ها و فايروال ها ايمني لازم را ندارد. ترافيك Telnet اساسا نام كاربري و كلمه عبور را در دسترس افرادي كه دائم به شبكه ها حمله مي كنند مي گذارد و اين افراد دقيقا افرادي هستند كه قصد سوء استفاده از اين اطلاعات جهت دسترسي به دستگاه هاي شبكه را دارند.بهترين جايگزين براي Telnet با مشكلات امنيتي مختص به خودش، SSH مي باشد. دقيقا شبكه Telnetشما مي توانيد از SSH براي دسترسي به دستورات IOS روي شبكه استفاده كنيد يا اينكه قادر خواهيد بود فايل هاي خود را در بستر شبكه انتقال داده و روي دستگاه خاصي كپي كنيد اما با SSH به دليل استفاده از كدگذاري و امضاي ديجيتال ديگر نگران موارد امنيتي و لو رفتن اطلاعات نخواهيد بود.telnet

[عکس: telnet.jpg]
در حال حاضر دو ورژن Secure Shellموجود است يعني SSH1 و SSH2 و Cisco IOS 12.1(3)T اولين ورژني بود كه SSH1 را پشتيباني مي كرد هرچند نياز به استاندارد كدگذاري اطلاعات DES يا 3DES را داشت.
ورژن هاي بعدي IOS يعني 12.3 تا 12.3(4)T ، 12.2(25)S و 12.3(7)JAو نسخه هاي بعدي اولين نسخه هايي بودند كه از SSH2 پشتيباني مي كردند كه نيازمند IOS اي بودند كه از 3DESپشتيباني مي كرد. IOSاي كه اي كه 3DES را پشتيباني مي كند K9در نام فايل خود دارد.اين مهم است كه بدانيد SSH1وSSH2دو پروتكل كاملا متفاوت هستند. SSH2 امنيت بيشتري را ارائه مي دهد و پيشنهاد من اين است كه در صورت امكان از اين ورژن استفاده كنيد هرچند كه SSH1 بسيار بهتر از Telnet مي باشد. آن شما را در برابر حملات معمولي كه به شنود روي شبكه شما براي پيدا كردن كلمه عبور ادامه مي دهند حفاظت خواهد كرد.
Cisco IOS هردو نسخه SSH Server و SSH client را پيشنهاد مي دهد لذا شما قادر خواهيد بود از طريق SSH Client به SSH Server روتر خود وصل شويد.
حال نحوه تنظيم SSHرا برروي يك Cisco IOS توضيح مي دهم. اين تنظيمات كاملا شبيه تنظيمي مي باشد كه شما برروي يك Cisco Switchيا Cisco Firewall مورد نياز خواهيد داشت.
بطور مثال كار خود را با يك روتر Cisco 2611 با IOS اي با ورژن 12.2(15)T9 كه شامل كدگذاري 3DESاست آغاز مي كنم. فايل مربوط به اين IOS نامي به صورت c2600-ik9o3s3-mz.122-15.T9.bin دارد.
ابتدا از داشتن hostname روي روتر خود مطمئن شويد. براي انجام اين منظور از دستور زير استفاده كنيد:
Router(config)# hostname TR-Router
TR-Router(config)#
سپس نام دامنه يا domain name را با استفاده از دستور ip domain-name روي روتر تنظيم كنيد. در اينجا مثالي را براي شما آورده ام:
TR-Router(config)# ip domain-name TechRepublic.com
TR-Router(config)#

پس از اين قسمت شما بايد كليد RSA encryption را جهت استفاده در authentication و encryption داده SSH تنظيم كنيد. يكي از سوال هايي كه در اين مرحله بايد به آن پاسخ دهيد اندازه ماژول كليد است. اندازه كليد ماژول حداقل بايد 768 بيت باشد. در اينجا مثالي را براي شما آورده ام:
TR-Router(config)# crypto key generate rsa
The name for the keys will be: TR-Router.TechRepublic.com
Choose the size of the key modulus in the range of 360 to 2048
for your General Purpose Keys. Choosing a key modulus greater than
512 may take a few minutes.

How many bits in the modulus [512]: 768
% Generating 768 bit RSA keys ...[OK]

TR-Router(config)#
*Mar 1 001713.337: %SSH-5-ENABLED: SSH 1.5 has been enabled
TR-Router(config)#
همانطور كه در اين مثال مي بينيد، پس از اينكه سيستم كليد خود را توليد مي كند شما پيغامي را دريافت مي كنيد كه بطور اتوماتيك SSH1.5را برروي روتر توليد مي كند. اين پيغام نشاندهنده اين است كه سيستم SSH1را بر روي روتر فعال نموده است. در صورتيكه سيستم كليد را براي هردو نسخه SSH1 و SSH2 توليد كرده باشد پيغامي كه به شما مي دهد نمايانگر فعال شدن SSH1.99 خواهد بود. درصورتيكه تنها SSH2فعال شده باشد سيستم پيغام فعال شدن پيغام را تنها بصورت SSH2.0 نمايش خواهد داد.
همچنين شما قادر خواهيد بود تنظيمات SSH را انجام دهيد براي اين منظور از دستور ip ssh را به همراه پارامترهاي آن مي توانيد استفاده كنيد. بديهي است كه نسخه هاي متفاوت IOS پارامترهاي مختلفي را به دليل استفاده از نسخه هاي متفاوت SSH خواهند داشت. در اينجا مثالي آورده شده است :
TR-Router(config)# ip ssh ?
authentication-retries Specify number of authentication retries
Port Starting (or only) port number to listen
on
Rsa Configure RSA keypair name for SSH
source-interface Specify interface for source address in SSH
connections
time-out Specify SSH time-out interval

TR-Router(config)# ip ssh

تنظيم انتخابي SSH تنظيم SSH را روي روتر كامل كرده و به انتها مي رساند. حال نگاهي به وضعيت SSH مي اندازيم لذا براي اين منظور از دستورات زير استفاده مي كنيم :
• Use show ip ssh to view SSH settings.
• Use show ssh to view SSH connections.
مثال:
TR-Router# show ip ssh
SSH Enabled - version 1.5
Authentication timeout: 120 secs; Authentication retries: 3
TR-Router# show ssh
%No SSH server connections running.
TR-Router#
همچنين شما مي توانيد از Buil-in SSH Client براي اتصال به ساير SSH Server ها استفاده كنيد. دستور پيشفرض ssh خواهد بود. در اينجا مثاالي آورده شده است :
TR-Router# ssh ?
-c Select encryption algorithm
-l Log in using this username
-o Specify options
-p Connect to this port
WORD IP address or hostname of a remote system

TR-Router# ssh

مترجم : كيانوش مراديان

منبع :http://articles.techrepublic.com.com
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط
#9
NAT در سيسكو
NAT يكي از ابزارهاي قدرتمند دنياي IT است كه دقيقا همان كاري را انجام مي دهد كه از اسم آن بر مي آيد,به وسيله NAT مي توانيم آدرس هاي يك شبكه را به يك شبكه ديگر ترجمه كنيم.NAT تقريبا در تمامي سيستم عامل ها و روتر ها قابل انجام است كه هر كدام شيوه و روش خود را دارند.براي همه متخصصين واضح است كه قوي ترين روتر هاي دنيا Cisco هستند و تقريبا 80 درصد از بستر اينترنت بر روي دستگاه هاي Cisco بنا شده اند. در اين آموزش به توضيح مراحل انجام NAT به صورت عملي بر روي سخت افزارهاي سيسكو مي پردازيم.

از كاربردهاي NAT مي توان به موارد زير اشاره كرد:



* ترجمه IP هاي Private به Public يا برعكس
* تغيير مركز سرويس دهنده اينترنت بدون نياز به تغيير IP ها داخلي
* حفاظت از يك شبكه حساس در مقابل برخي حملات خارجي
* تغيير پورت مقصد پكتها براي كاربران داخلي به صورت transparent



تعريف برخي اصطلاحات:

* Inside Local : به آدرس (هايي) اتلاق ميشود كه بر روي كلاينتهاي شبكه داخلي تنظيم شده اند.
* Inside Global : به آدرسي اتلاق ميشود كه به اينترفيس داخلي روتر كه به شبكه داخلي متصل است داده شده است.
* Outside Local : به آدرس هايي كه درون اينترنت يا شبكه Public ما قرار دارد گفته مي شود.
* Outside Global : به آدرس (هايي) كه بر روي اينترفيس خارجي روتر كه به شبكه Public متصل است گفته مي شود.


با يك مثال تصويري با اصطلاحات فوق بيشتر آشنا خواهيم شد.
[عکس: staticnat.png.jpg]


Static NAT
[عکس: nat.png]
اين نوع NAT به صورت يك به يك عمل مي كند. بدين معني كه يك عدد inside-localرا به يك outside-global ترجمه مي كند. كاربرد اين نوع NAT وقتي است كه ميخواهيم يك private ip را به يك public ip تبديل كنيم.با مثالي عملي آن را بيشتر توضيح مي دهيم.



nat
در مثال فوق يك روتر سيسكو داريم كه 2 عدد اينترفيس دارد. يكي سريال كه به اينترنت متصل و دومي اترنت كه به شبكه داخلي ما وصل شده است.
ما ميخواهيم آدرس 10.1.1.1را به 11.11.11.254ترجمه كنيم.
بر روي روتر سيسكو چنين عمل مي كنيم:

وارد محيط config مي شويم

config terminal

با اين دستور يك NAT استاتيك مي سازيم

ip nat inside source static 10.1.1.1 11.11.11.254

وارد اينترفيس سريال مي شويم

interface serial0

اين اينترفيس را به عنوان خروجي NAT مشخص مي كنيم

ip nat outside

از اينترفيس خارج مي شويم

exit

وارد اينترفيس اترنت مي شويم

interface Ethernet0

اينترفيس را به عنوان ورودي NAT مشخص مي كنيم

ip nat inside

از اينترفيس و مد Config خارج مي شويم



هم اكنون با تنظيم كردن آدرس 10.1.1.1و گيت وي 10.10.10.10روي كلاينت مي توانيم به اينترنت دسترسي داشته باشيم.



Dynamic NAT

Dynamic NAT نيز همانند Static NAT است اما با اين تفاوت كه در NAT به صورت Dynamic مي توانيم يك يا چندين IP با به چندين IP ترجمه كنيم.

اما چرا چندين IP به چندين IP؟

فرض كنيد شما Admin يك ISP هستيد و به دليل كمبود IP نياز به NAT داريد. بر فرض مثال شما داراي 10 Valid IP و 100 Invalid IP كه بايد به آنها ترجمه كنيد. ممكن است تا كنون براي شما پيش آمده باشد كه كاربري تماس گرفته و اعلام نا رضايتي كند از اينكه مدتهاي طولاني براي دانلود يك فايل از سايت Rapidshare.com بايد انتظار بكشد. اين به دليل اين است كه سايت Rapidshare.com تمامي كاربرهاي شما را به چشم يك كاربر مي بيند. براي رفع اين مشكل مي توانيم 10 آدرس معتبر را به 100 آدرس غير معتبر ترجمه كنيم كه تا حدود زيادي مشكل را حل خواهد كرد.
در Dynamic NAT معمولا آدرس هاي معتبر را به وسيله IP nat pool مشخص و آدرس هاي غير معتبر را توسط يك access-list مشخص مي كنيم. دليل استفاده از access-list ايجاد امنيت بيشتر است.

حال با يك مثال به نحوه ايجاد يك Dynamic NAT واقف مي شويم:

يك روتر سيسكو داريم كه از يك سو توسط اينترفيس سريال به اينترنت متصل گرديده كه داراي رنج IP 217.219.109.128/25 و از سوي ديگر توسط اينترفيس اترنت به شبكه داخلي با رنج 172.16.0.0/24 متصل شده است.

آدرس اينترفيس سريال را 217.219.109.129 و آدرس اينترفيس اترنت را 172.16.0.1 قرار ميدهيم.


config terminal

ابتدا براي آدرسهاي Valid خود يك Pool تهيه مي كنيم

ip nat pool pool1 217.219.109.130 217.219.109.254 prefix-length 25

Prefix-length در مثال بالا همان subnet mask آدرس هاي ما مي باشد
حال access-list مربوط به آدرس هاي داخلي را مي نويسيم

access-list 8 permit 172.16.0.0 0.0.0.255

دستور اصلي NAT را مي نويسيم

ip nat inside source list 8 pool pool1

كه در دستور فوق عدد 8 بيانگر آدرسهاي داخلي و pool1 مشخص كننده آدرس هاي خارجي است

interface serial0

اينترفيس را به عنوان خروجي NAT مشخص مي كنيم

ip nat outside

از اينترفيس خارج مي شويم

exit

وارد اينترفيس اترنت مي شويم

interface ethernet0

اينترفيس را به عنوان ورودي NAT معرفي مي كنيم

ip nat inside





Dynamic NAT به صورت Overload


ممكن است ما به شرايطي بر بخوريم كه تنها 1 عدد آدرس Valid در اختيار داريم و اجبار به NAT كردن آدرس مذكور به چندين آدرس را داريم. در چنين شرايطي بايد از قابليت Overload استفاده كنيم.
در اين حالت روتر براي ورود و خروج هر آدرس Invalid يك پورت مجزا در نظر مي گيرد كه تمامي آنها را در جدولي كه درون خود تشكيل مي دهد به ثبت مي رساند. به اين ترتيب هر بسته كه از روتر به مقصد اينترنت خارج مي شود دقيقا در هنگام بازگشت به همان آدرس Invalid كه صادر كننده آن است باز مي گردد. هر يك خط در جدول مذكور يك كانكشن به حساب مي آيد. اگر دقت كنيد بر روي كاتالوگ بعضي سخت افزارها محدوديتي براي تعداد اين كانكشن ها قائل مي شوند.

در مثال زير نحوه تنظيم يك روتر به صورت Overload را توضيح مي دهيم :

دياگرام خود را مقداري تغيير مي دهيم. در اين مثال ما روتر خود را كه داراي 3 اينترفيس است به 3 شبكه متصل مي كنيم. پورت سريال كه به اينترنت متصل و داراي آدرس 80.191.120.8/26 است . اينترفيس ethernet0 به شبكه داخلي اول ما متصل و داراي آدرس 172.16.100.1/24 ميباشد و در آخر اينترفيس ethernet1 را داريم كه داراي آدرس 192.168.30.1/24 است.
مي خواهيم آدرس 80.191.120.8 را به دو subnet داخلي NAT كنيم:

وارد مد كانفيگ مي شويم

config terminal

يك pool براي آدرس Valid تهيه مي كنيم كه تنها 1 آدرس در آن وجود دارد

ip nat pool ovrld 80.191.120.8 80.191.120.8 netmask 255.255.255.192

با access-list زير آدرس هاي دو رنج داخلي خود را به access-list شماره 3 نسبت مي دهيم

access-list 3 permit 172.16.100.0 0.0.0.255
access-list 3 permit 192.168.30.0 0.0.0.255

دستور اصلي NAT را مي نويسيم كه كلمه Overload مي بايست در آخر آن اضافه شود

ip nat inside source list 3 pool ovrld overload

اينترفيس خروجي NAT را مشخص مي كنيم

interface serial0
ip nat outside
exit

اين اينترفيس را به عنوان ورودي NAT مشخص مي كنيم

interface ethernet0
ip nat inside
exit

اين اينترفيس را به عنوان ورودي NAT مشخص مي كنيم

interface ethernet1
ip nat inside
exit


هم اكنون آدرس 80.191.120.8 عمل NAT را براي هر دو سابنت ما انجام مي دهد.



Destination NAT



dstNAT يا outside source address translation بدين معني است كه ما عمل NAT را براي شبكه Public خود انجام دهيم. با يك مثال قضيه را روشن ميكنم:
فرض كنيد آدرس IP يكي از مشتركين شما NAT شده است. يعني مشترك به صورت دستي آدرس را در كامپيوتر خود وارد كرده و default gateway را آدرس اينترفيس داخلي روتر شما قرار داره است. شما قبلا عمل NAT را براي وي انجام داده ايد و او را به اينترنت متصل نموده ايد. حال مشترك نياز دارد كه كاربري در اينترنت به كامپيوترش وصل شود يا اينكه قصد هاست كردن يك وبسايت بر روي كامپيوتر حود را دارد. با شرايط فعلي اين امر امكان پذير نيست زيرا كه آدرس معتبري ير روي آن تنظيم نشده و از اينترنت قابل رويت نيست.ما براي رفع مشكل اين يوزر مي بايست عمل dstNAT را انجام دهيم. يعني به روتر خود بگوئيم هر گاه پكتي با درخواست اتصال به آدرس X را داشت آن را به كامپيوتري در شبكه داخلي با آدرس Y بفرست. بدين ترتيب با داشتن آن آدرس valid ميتوانيم به هاست لوكال خود دسترسي پيدا كنيم. اين امر نيز به دو صورت static و dynamic قابل اجراست كه در مثالهاي زير توضيح داده شده است.




Static dstNAT

ابتدا همانند قبل يك static nat ميان 2 آدرس 10.1.1.1 و 11.11.11.254 ايجاد مي كنيم سپس اين خط را به تنظيمات خود اضافه ميكنيم

ip nat outside source static 11.11.11.254 10.1.1.1




Dynamic dstNAT


در اين مثال نيز ابتدا تمامي تنظيمات Dynamic NAT را كه قبلا گفته شده انجام مي دهيم سپس اين خط را به آخر آن اضافه مي كنيم

ip nat outside source list 8 pool pool1


بدين ترتيب عمل reverse را نيز براي NAT خود انجام مي دهيم.




Redirect in NAT


در بعضي مواقع نياز داريم كه يك پورت يا IP را به صورت transparent براي يوزرهاي خود عوض كنيم. به عنوان مثال ما در شبكه خود يك وب سرور داريم. اين سرور قبلا بر روي پورت 80 كار كرده است اما اكنون به دلايلي مجبور به تعويض پورت آن به 8080 شده ايم. ممكن است آگاه سازي يوزرهاي ما برايمان مشكل ساز باشد و بخواهيم بدون هيچ تغييري براي آنها اين پورت را عوض كنيم. در چنين مواقعي Redirect به كمك ما مي شتابد.
در مثال زير با چگونگي تنظيمات اين نوع NAT آشنا مي شويم:

در اين مثال ما يك روتر سيسكو داريم كه 2 اينترفيس سريال و اترنت دارد. كه آدرس سريال را 100.100.100.5 و آدرس اترنت را 10.20.30.1 قرار داده ايم.
آدرس وب سرور ما 10.20.30.55 مي باشد كه در شبكه داخلي ما قرار دارد.
براي Redirect كردن پورت 80 به 8080 بدين صورت عمل ميكنيم:

config terminal
ip nat inside source static tcp 10.20.30.55 8080 10.20.30.55 80

اينترفيس خروجي NAT را مشخص مي كنيم

interface serial0
ip nat outside
exit

اين اينترفيس را به عنوان ورودي NAT مشخص مي كنيم

interface ethernet0
ip nat inside
exit


حال يك سولوشن ديگر پياده مي كنيم.

در شبكه ما يك روتر وجود دارد كه داراي 3 اينترفيس است. اينترفيس سريال كه آدرس 200.200.200.43 و اينترفيس ethernet0 كه آدرس 172.16.10.1 و اينترفيس ethernet1 كه آدرس 192.168.0.1 را داراست.
ما در شبكه اي كه به اينترفيس ethernet1 متصل شده يك سرور داريم كه آدرس آن 192.168.0.6 است. به دلايلي مجبور به تعويض آدرس آن به 192.168.0.12 شده ايم. به دليل اينكه اين سرور مربوط به اتوماسيون اداري ما بوده بسيار كار دشواريست كه بر روي 176 كلاينت خود كه با اين سرور كار ميكنند و در شبكه اي كه به اينترفيس ethernet0 وصل است آدرس سرور را عوض كنيم.
براي همين به سراغ روتر قدرتمند خود مي آئيم و تمامي درخواستهايي را كه به مقصد 192.168.0.6 مي روند را به 192.168.0.12 هدايت ميكنيم.
در زير نحوه انجام اين كار توضيح داده شده است.

config terminal
ip nat inside source static 192.168.0.12 192.168.0.6

اينترفيس خروجي NAT را مشخص مي كنيم

interface serial0
ip nat outside
exit

اين اينترفيس را به عنوان ورودي NAT مشخص مي كنيم

interface ethernet0
ip nat inside
exit

اين اينترفيس را به عنوان ورودي NAT مشخص مي كنيم

interface ethernet1
ip nat inside
exit



Change Translation Timeouts


وقتي كه ما از Dynamic NAT استفاده مي كنيم يك IP به يك IP ديگر نسبت داده مي شود. فرضا اگر كلاينت ما 1 ساعت از اين IP استفاده كند تا يك مدت بعد اين IP خارجي براي وي به صورت رزرو مي ماند. اگر بعد از يك پريود زماني كلاينت ما از آن استفاده نكند به كلاينت ديگري اختصاص داده مي شود.
زمان اين تاخير را ميتوانيم مشخص كنيم كه در حالت Dynamic NAT بدون Overload اين زمان به صورت پيش فرض 24 ساعت است.

با دستور زير اين امر محقق مي شود:

config terminal
ip nat translation timeout 21600

عدد فوق بر اساس ثانيه بوده كه در مثال بالا ما اين زمان تاخير را بر روي 6 ساعت تنظيم كرده ايم.

همانطور كه گفتيم مثال بالا براي حالت Dynamic NAT بدون Overload هست. در حالت Overload چون براي هر يوزر يه آدرس خارجي نداريم مقدار اين زمان اصلا مشخص نيست.
در حالت Overload تنها ميتوانيم زمان براي پروتكلهاي خاص مشخص كنيم:

در مثال زير پروتكلها آورده شده اند:

config terminal
ip nat translation udp-timeout 120
ip nat translation dns-timeout 100
ip nat translation tcp-timeout 480
exit

مانيتور كردن NAT درون Router

show ip nat translations
show ip nat statistics


*با تشكر از وب سايت cisco.parsfa.com بابت اين مقاله خوب و كامل
[عکس: www.Mojsazan.com.gif]
پاسخ
سپاس شده توسط


موضوعات مشابه ...
موضوع نویسنده پاسخ بازدید آخرین ارسال
  قوانین و قراردادهای نام گذاری نرم افزارهای سیسکو (IOS Images) morteza ghaem 1 614 09-26-2013, 01:53 PM
آخرین ارسال: mohammad.safizade
  دانلود Cisco Secure ACS 5.2 همراه با آموزش کرک myside 0 1,427 06-20-2013, 02:36 PM
آخرین ارسال: myside
  نکاتی در زمینه سویچ های سیسکو مهرداد عباسی 0 1,260 10-23-2012, 09:54 PM
آخرین ارسال: مهرداد عباسی
  معرفی IP SLA در سیسکو مهرداد عباسی 0 1,117 09-22-2012, 09:46 AM
آخرین ارسال: مهرداد عباسی
  IOS 15 سیسکو morteza ghaem 0 826 06-22-2012, 10:16 AM
آخرین ارسال: morteza ghaem
  انواع IOS در سیسکو morteza ghaem 0 1,089 06-22-2012, 10:08 AM
آخرین ارسال: morteza ghaem
  PIX,ASA,FWSM سیسکو morteza ghaem 3 1,443 06-18-2012, 10:19 AM
آخرین ارسال: morteza ghaem
  چگونه IOS سیسکو را ارتقا دهيم morteza ghaem 0 1,221 06-10-2012, 05:23 PM
آخرین ارسال: morteza ghaem
  تعريف DNS برای روتر سیسکو morteza ghaem 0 1,211 06-10-2012, 03:03 PM
آخرین ارسال: morteza ghaem
  لینکهای مرجع سیسکو morteza ghaem 0 1,168 06-07-2012, 05:26 PM
آخرین ارسال: morteza ghaem

پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان